Для обновления Joomla с 1.5 до 2.5 используется компонент jUpgrade

Требования для работы jUpgrade:

  • PHP v5.2.4+
  • IIS/Windows: MySQL v5.1 - Linux/Apache: MySQL v5.0.4+
  • Curl module of PHP enabled
  • Joomla 1.5
  • Enable  System - Mootools Upgrade plugin that is included in Joomla 1.5.19 and greater.
  • A Browser with Javascript/jQuery support

Добавлю сюда, что кроме Curl module на хостинге нужно включить еще и ctype PHP модуль.

Иначе на шаге миграции пишет Migration Undefined и при включенной отладочной информации в jUpgrade, выводится сообщение об ошибке:

call to undefined function ctype_alpha

ctype это расширение для определения типов символов.

На что еще можно обратить внимание.. Должен быть включен модуль PHP mysqli. Также та nic.ru joomla не обновлялась при версии PHP 5.2, после смены версии PHP на хостинге, обновление прошло успешно.

Так вот выглядит процесс обновления:

Комментарии   

#3 www.ICaR-Soft.ru 04.05.2013 00:53
А без этой RedCompanent, где нужно писать и адрес и год рождения и сколько у тебя родинок на левой пятке, можно обновить Joomla?
Или это фишка Jooml'ы - быть необновляемой, пока не обновят через написанный слева модуль?
#2 Николай 21.11.2012 15:08
А если включить вывод отладочной информации в jUpgrade, что пишет?
#1 Егор 21.11.2012 12:36
Системные требования подходят, модули включены, при обновлении все равно вылазит Migration Undefined

Чтобы сделать комментарий, нужно авторизоваться на сайте!